Welcome, Guest ( Customer Panel | Login )




 All Forums
 VPCart Forum
 Search Engine Optimisation
 Any suggestions for moving homepage
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

FCS-Webmaster
VP-CART New User

Canada
117 Posts

Posted - July 04 2016 :  19:54:09  Show Profile  Visit FCS-Webmaster's Homepage  Reply with Quote
Our website has been online for eons. At the time when we setup the website back in 1997 splash pages or welcome pages were normal as people back then didn''t just barge in to someones website ;-).

Now as far as we are aware there seems to be an SEO penalty as redirecting your home page seems to effect your domain authority. That''s our guess as our Moz domain authority is a 25 and our other domain that we use mostly for load balancing and serving up images is a 30.

Its too bad we didn''t know that in February when we upgraded to VPASP version 8 as that would have been an easy fix at that point for us to move from http://www.fcsurplus.ca/shopping/default.asp to http://www.fcsurplus.ca.

At this point the only two options we have been able to come up with is to try to go through the default.asp files and all the files it calls in (which is a lot) and try to either make new ones in the root directory or make another installation of VPASP from the root directory just to run the new home page. Anyone care to offer feedback or a better suggestion?

squirrel
VP-CART New User

USA
73 Posts

Posted - July 04 2016 :  20:18:57  Show Profile  Reply with Quote
@FCS-Webmaster

If you have upgraded your cart to VPASP version 8 in February, that would have been an older version. Currently, if I am not mistaken...the latest is version 8.1.0.3.

I would suggest that you upgrade your cart to the very latest (if you dont have much customisation). However, if you have customised your shopping cart, the best will be to set up a new subdomain (preferably, called v2.fcsurplus.ca) and try moving your shopping folder to this new subdomain. Dont forget to update the config files with the new subdomain''s url.

Set and tweak everything up in your subdomain and once you are happy with it, just back up the entire httpdocs folder into something called ''backuphttpdocs'' and move the v2 folders into httpdocs instead. Again, dont forget to rename your site''s url in the config files.

Always backup every single folder before moving them here and there. Also, dont forget to backup you database if you choose to run the upgrade wizard.

Good luck :)

Thank you.

Best Regards,
Daniel

Be Happy Always
Go to Top of Page

diegomilito
VP-CART Expert

Argentina
766 Posts

Posted - July 18 2016 :  21:50:52  Show Profile  Reply with Quote
FCS, i got an idea for you,
your v8 files are at shopping folder right ?

try setup something like this:
a.copy v8 default.asp to root
b.edit default.asp
<!#include file="shop$db.asp"-->
you must have something changed to like this:
<!--#include file="shopping/shop$db.asp"-->

c.copy the ''templates'' folder to root
d.copy the ''js'' folder to root
e.copy the ''common'' folder to root

that''s it.

diego.
Go to Top of Page

danielrichardson
VP-CART New User

Australia
188 Posts

Posted - July 28 2016 :  07:36:39  Show Profile  Reply with Quote
Awesome tutorial diego, another post that should be save. thanks
Go to Top of Page

FCS-Webmaster
VP-CART New User

Canada
117 Posts

Posted - March 15 2019 :  20:04:53  Show Profile  Visit FCS-Webmaster's Homepage  Reply with Quote
I feel awful that I''m just getting around again to make another attempt at this.

I estimate I''m about 70% of the way their with Diego''s help.

Here''s where I''m at so far. I assume at this point it will be a matter of trying to debug CSS problems and figuring out why it''s not connecting to the database (this is causing search and category pages from showing).
https://www.fcsurplus.ca/default-timtest20190315.asp

For me I had to add images category as the F in Diego''s list.

The top slider banners looks like it is a problem, but the same problem exists if that is turned off. I assume if I can sort out the database connectivity that may solve that issue.
Go to Top of Page

diegomilito
VP-CART Expert

Argentina
766 Posts

Posted - March 15 2019 :  23:52:30  Show Profile  Reply with Quote
what is your db issue buddy?

i m looking your page is loading products ok ? https://www.fcsurplus.ca/default-timtest20190315.asp

it just css issue you must fix?

diego
Go to Top of Page

FCS-Webmaster
VP-CART New User

Canada
117 Posts

Posted - March 18 2019 :  17:02:41  Show Profile  Visit FCS-Webmaster's Homepage  Reply with Quote
If you do a search that will give an error. If you scroll further down the category list is a funny looking iframe like structure into a 404 page. I''ll take a look at it some more tomorrow.
Go to Top of Page

diegomilito
VP-CART Expert

Argentina
766 Posts

Posted - March 20 2019 :  22:23:53  Show Profile  Reply with Quote
i can see that, of course it will 404 the time you search, when i look at your search form you did the wrong thing:
<form method="post" action="shopsearch.asp?search=Yes" id="welcomeboxstretchform3" name="welcomeboxstretchform3">

you told the form to post action to page shopsearch.asp, in fact your cart is at shopping folder?
my friend, this will not work,. then you must change the form action to shopping/shopsearch.asp etc

diego
Go to Top of Page

FCS-Webmaster
VP-CART New User

Canada
117 Posts

Posted - March 22 2019 :  18:36:42  Show Profile  Visit FCS-Webmaster's Homepage  Reply with Quote
Diego, thanks for all your help. I really appreciate it.

Good news is I have the CSS all fixed up.

Now just down to the search and the categories to fix before I can go live.

I changed the address of the form as you suggested and I still have the same problem.

I tried copying over the shopsearc.asp to the root, changing the directories to the shopping directory, and I have the same problem as the homepage.
https://www.fcsurplus.ca/shopsearch.asp
Go to Top of Page

diegomilito
VP-CART Expert

Argentina
766 Posts

Posted - March 23 2019 :  05:00:14  Show Profile  Reply with Quote
i revisited ur page again https://www.fcsurplus.ca/default-timtest20190315.asp i viewed source again, your search form still same like the first time i saw it, still wrong action value that missed the shopping folder
<form method="post" action="shopsearch.asp?search=Yes" id="welcomeboxstretchform3" name="welcomeboxstretchform3">

you must change to something below friend-
<form method="post" action="shopping/shopsearch.asp?search=Yes" id="welcomeboxstretchform3" name="welcomeboxstretchform3">

give it a try again and you should see it right
diego
Go to Top of Page

FCS-Webmaster
VP-CART New User

Canada
117 Posts

Posted - April 01 2019 :  20:03:45  Show Profile  Visit FCS-Webmaster's Homepage  Reply with Quote
Thanks again Diego for your help.
I''m stumped. It sounds so simple, yet I''m not sure why I can''t get it to work.

The only spot that I could see that I could change it was in the load_topheaderlowerleftbox_search sub procedure.

I changed <form method="post" action="shopsearch.asp?search=Yes" id="<%=prefix%>form3" name="<%=prefix%>form3"> to
<form method="post" action="shopping/shopsearch.asp?search=Yes" id="welcomeboxstretchform3" name="welcomeboxstretchform3">

I took some screenshots of the results as I didn''t want to disturb the production site.
https://airsoftadventure.ca/ta-products/new-directory-not-working.jpg

Edited by - FCS-Webmaster on April 02 2019 10:37:52
Go to Top of Page

diegomilito
VP-CART Expert

Argentina
766 Posts

Posted - April 09 2019 :  03:48:00  Show Profile  Reply with Quote
im not sure i tried to load your site again for 3rdtime and i m viewing source your code near the top right search box, i still see your incorrect form post location:

<form method="post" action="shopsearch.asp?search=Yes" id="welcomeboxstretchform3" name="welcomeboxstretchform3">

I have given you solultion before,,, you may need to look at somewhere in the asp file that contains this form and change the target to shopping/shopsearch.asp..

diego
Go to Top of Page

tomfor
Starting Member

2 Posts

Posted - July 16 2020 :  02:20:49  Show Profile  Reply with Quote
I need help setting up redirects from old products to new ones on my site https://www.rocketbadge.co.uk/. How to do it right? Or create new pages and keep 404 pages?

Edited by - tomfor on July 17 2020 05:47:27
Go to Top of Page

swampthink
VP-CART New User

67 Posts

Posted - July 16 2020 :  09:09:17  Show Profile  Reply with Quote
Hi Tomfor,

Maybe you can use web.config for the redirect. eg;

<rewrite>
<rules>
<rule name="[RULE NAME]" stopProcessing="true">
<match url="(.*)" />
<conditions logicalGrouping="MatchAny" trackAllCaptures="false">
<add input="{HTTP_HOST}{REQUEST_URI}" pattern="[OLD URL]" />
<add input="{HTTP_HOST}{REQUEST_URI}" pattern="www.[OLD URL]" />
</conditions>
<action type="Redirect" url="http://[NEW URL]" redirectType="Permanent"/>
</rule>
</rules>
</rewrite>
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000
0 Item(s)
$0.00